About Template

共有テンプレート一覧はこちら

OK

  • カスタマイズ
  • 素材の入れ替え

NG

  • 素材及びテンプレートの再配布
  • 著作権表記及びリンクの削除、改変
  • アダルト・違法・宗教関連のサイトでの使用
  • fc2ブログ利用規約の禁止行為に該当するサイトでの使用

詳細は「テンプレートの利用について」をご覧ください。



WordpressプラグインComprehensive Google Map Pluginのエラー

Wordpressを3.5.Xから3.6.1にアップグレードしました。

最も懸念していたのは、キャッシュ系のプラグインが悪さをしないかだったんですが、そちらは大丈夫でした。
キャッシュ系のプラグインは、いつもアップグレードとかするたびに重大がエラーが出ないかどうか不安で心臓に悪いので、とりあえずプラグインもアップグレードだけして有効化しないでおきました。
これ、このまま削除しても大丈夫なのだろうか。
以前、削除しようとしたら管理画面真っ白とかいろいろと大変なことになったので、とりあえずそのまま。

さて、一つだけ大きなエラーが出ました。

Googlemapのプラグイン「Comprehensive Google Map Plugin」です。

サイトを表示させると、ブラウザに

ATTENTION! (by Comprehensive Google Map Plugin)

Your blog/site theme or one of your plugins uses jQuery javascript library which is older than the version 1.3.0.
The Comprehensive Google Map plugin will not work with such outdated jQuery version.

The minimum jQuery requirement for Comprehensive Google Map plugin is version 1.3.0. Apologies for the inconvenience.


という文章が表示されちゃうんです。


Wordpressのフォーラムで調べたら、作者様からのお返事は無かったものの、有志の方が解決方法を提示されていたので、早速修正させていただきました。ホッ。


以下、解決方法メモです。


該当プラグインのフォルダ内、

assets/js/cgmp.framework.min.js

ファイル内の

if(1.3>m)return alert(i.oldJquery),!1;

を以下に変更

if(1.1>m)return alert(i.oldJquery),!1;


そして、

assets/js/cgmp.framework.js

ファイル内の

var version = parseFloat($.fn.jquery);
if (version < 1.3) {



var version = parseFloat($.fn.jquery);
if (version < 1.1) {

に変更です。

Profile

Neriko

Author:Neriko
遊ぶべ!道南探検隊

本サイトは「遊ぶべ!道南探検隊」

はこだて・こどもずかん

→ もっと詳しく

最新記事のRSS

Entry+Comment

Tag+Search


Sponsor

Calendar

07 | 2013/09 | 10
1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30 - - - - -

Link

QRcode

QR

Mailform

Name:
Email:
Title:
Message: